Anmelden | registrieren | Kategorien



 
zurück zum Forum neuer Eintrag
Ansicht:   
Infopost Aktuelles: > [Wichtige Forumsinformationen] [NT-Karte] [NT-Fotos] [NT-Fotowettbewerb]

#414046 Excel XP: Zell-Adresse ausrechnen - DANKE! (pc.sw.office)

verfaßt von neanderix, 25.07.2017, 19:29:22

> Hallo und Danke für die guten Tipps!
>
> > > Ich kapier bloß nicht, warum man diese "Matrix" angeben muss.
> >
> > Die "Matrix" ist der Bereich, in dem SVERWEIS suchen soll
>
> Jaaa - aber es soll doch nur in einer einzigen Spalte gesucht werden! Dafür
> aber bitte in der gesamten Spalte.

Jetzt versteh' ich was du meinst. Gut, warum MS meinte, dass der SVERWEIS die Parameter als spalten einer matrix braucht - das musst du MS fragen  :smoke:

> (Das ist übrigens meine Angewohnheit, z.B. Summen von Spalten nie unter
> dieses Spalte zu schreiben, sondern woanders hin. So kann ich immer eine
> gesamte Spalte aufsummieren, ganz egal, wie da was ein- oder angefügt wird.
> Summ(A:A) tut immer das, was ich will.)

Ich gehe da so vor, wie unten:
Spalte mit Namen versehen und unten drunter oder sonstwohin =Summe(MeineSpalte) - fertig.
Hat den Vorteil dass ich mir nicht Beschränkungen auferlegen muss ;)

>
> > > Und es fuchst
> > > mich, dass ich darin die höchste Zeilennummer angeben muss, weil sie
> die
> > > Tabelle immer mal wieder vergrößert. Nun gut, derzeit sind's 83 Zeilen
> -
> > > ich hab mal 1000 reingeschrieben.
> >
> > Nimm nur die aktuelle Zeilenzahl plus zwei.Wenn du jetzt diese Tabelle
> > vergrößerst, dann fügst du die nächste zeile *nicht* durch bloßes
> > hinschreiben an, sondern gehst zur ersten leeren zeile und nutzt
> > Zellen-Einfügen" (bzw. bei Rechtsklick auf den Zeilenkopf "Einfügen -
> > Zeile".
> > Auf diese Weise fügst du eine Zeile zu dem Bereich hinzu, den du
> SVERWEIS
> > als "Matrix" angegeben hast und der Bereich wird in der Formel
> automatisch
> > angepasst.
>
> Ja klingt gut, und das mit dem Rechtsklick auf den Zeilenkopf kannte ich
> noch nicht.
> Das Problem ist halt nur: Vergisst man das EIN mal, hat man möglicherweise
> einen Fehler in der Tabelle, den man NIE findet.
Deswegen einen Rahmen um den gesamten benamten Bereich legen, das ist eine gute Gedächtnisstütze: stehen zeilen ausserhalb der Rahmenlinien, kann was nicht stimmen ;)

> > Noch eleganter:
> > Der "Matrix" via STRG F3 einen Namen geben und dann diesen in die Formel
> > eintragen, statt des sperrigen
> > Tabelle_1!A2:B1000
> >
> > So liest sich die Formel auch gleich leichter:
> > =SVERWEIS(MAX(Tabelle_1!A:A);MeineTbelle;2;FALSCH)
>
> Das ist ja mal interessant: Ich hab bei der Definition des Namens einfach
> die gesamten Spalten A und B markiert und die "benamt". Trotz "Spaltenkopf"
> in der ersten Zeile wird das so gefressen. Super!
> (Aber vermutlich hätte ich auch ohne einen Namen zu vergeben einfach beide
> Spalten markieren können.)
>
> > liesst sich meiner Meinung nach doch einiges leichter als:
> > =SVERWEIS(MAX(Tabelle_1!A:A);Tabelle_1!A2:B1000;2;FALSCH)
> >
> > und auf die Spitze getrieben (d.h. der ersten Spalte der Tabelle1 einen
> > Namen gegeben):
> >
> > =SVERWEIS(MAX(MyData);MeineTabelle;2;FALSCH)
>
> Ja, danke - das habe ich jetzt auch mal gemacht. Ob es die
> Übersichtlichkeit wirklich steigert, weiß ich nicht so recht. Wenn ich die
> Namen nicht selber gut wähle, sieht man ja nichtmal, aus welchem Blatt das
> kommt.

Genau das Problem hatte ich auch mal. Jetzt löse ich das Problem so, dass ich den Namen bzw. Teile des Namens der jweiligen Quelltabelle mit in den Bereichsnamen einbinde.

Volker

--
Exil-Spotlighter

Probleme mit Windows? Reboot
Probleme mit Unix? Be root

antworten
 

gesamter Thread:

zurück zum Forum neuer Eintrag
Ansicht:   

weitere Informationen
Netz-Treff | Kontakt | Impressum | Nutzungsbedingungen | Datenschutz
28587 Beiträge in 2222 Threads (Archiv: 517169 Beiträge in 44017 Threads), 1188 registrierte Benutzer, 57 User online (5 User, 52 Gäste)
based on a 2004 version of my little forum  RSS-Feed  ^