Anmelden | registrieren | Kategorien



 
zurück zum Forum neuer Eintrag
Ansicht:   
Infopost Aktuelles: > [Wichtige Forumsinformationen] [NT-Karte] [NT-Fotos] [NT-Fotowettbewerb]

#413996 Excel XP: Zell-Adresse ausrechnen - DANKE! (pc.sw.office)

verfaßt von neanderix, 24.07.2017, 18:25:35

> > Hallo
> >
> > Das müsste mit SVerweis möglich sein, z.B. so:
> > =SVERWEIS(MAX(A1:A5);A1:B5;2;FALSCH)
> > wenn Deine Daten im Bereich A1:B5 stehen.
>
> 1000 Dank, Manes! Das klappt:
> =SVERWEIS(MAX(Tabelle_1!A:A);Tabelle_1!A2:B1000;2;FALSCH)
>
> Ich kapier bloß nicht, warum man diese "Matrix" angeben muss.

Die "Matrix" ist der Bereich, in dem SVERWEIS suchen soll

Und es fuchst
> mich, dass ich darin die höchste Zeilennummer angeben muss, weil sie die
> Tabelle immer mal wieder vergrößert. Nun gut, derzeit sind's 83 Zeilen -
> ich hab mal 1000 reingeschrieben.

Nimm nur die aktuelle Zeilenzahl plus zwei.Wenn du jetzt diese Tabelle vergrößerst, dann fügst du die nächste zeile *nicht* durch bloßes hinschreiben an, sondern gehst zur ersten leeren zeile und nutzt Zellen-Einfügen" (bzw. bei Rechtsklick auf den Zeilenkopf "Einfügen - Zeile".
Auf diese Weise fügst du eine Zeile zu dem Bereich hinzu, den du SVERWEIS als "Matrix" angegeben hast und der Bereich wird in der Formel automatisch angepasst.
Noch eleganter:
Der "Matrix" via STRG F3 einen Namen geben und dann diesen in die Formel eintragen, statt des sperrigen
Tabelle_1!A2:B1000

So liest sich die Formel auch gleich leichter:
=SVERWEIS(MAX(Tabelle_1!A:A);MeineTbelle;2;FALSCH)

liesst sich meiner Meinung nach doch einiges leichter als:
=SVERWEIS(MAX(Tabelle_1!A:A);Tabelle_1!A2:B1000;2;FALSCH)

und auf die Spitze getrieben (d.h. der ersten Spalte der Tabelle1 einen Namen gegeben):

=SVERWEIS(MAX(MyData);MeineTabelle;2;FALSCH)

Direktverweise mache ich in meinen Formeln nur noch selten - das hilft auch ungemein, Fehler zu vermeiden.

Volker

--
Exil-Spotlighter

Probleme mit Windows? Reboot
Probleme mit Unix? Be root

antworten
 

gesamter Thread:

zurück zum Forum neuer Eintrag
Ansicht:   

weitere Informationen
Netz-Treff | Kontakt | Impressum | Nutzungsbedingungen | Datenschutz
27697 Beiträge in 2162 Threads (Archiv: 519864 Beiträge in 44213 Threads), 1203 registrierte Benutzer, 44 User online (3 User, 41 Gäste)
based on a 2004 version of my little forum  RSS-Feed  ^